Einführung

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: PDF-Hilfedokumente einfach erstellen


PASCAL

Free Pascal Compiler (FPC)

Überblick

Free Pascal ist ein ausgereifter, vielseitiger, quelloffener Pascal-Compiler. Er kann für viele Prozessorarchitekturen eingesetzt werden: Intel x86 (16 und 32 bit), AMD64/x86-64, PowerPC, PowerPC64, SPARC, SPARC64, ARM, AArch64, MIPS, Motorola 68k, AVR, und die JVM. Zu den unterstützten Betriebssystemen gehören Windows (16/32/64 Bit, CE und natives NT), Linux, Mac OS X/iOS/iPhoneSimulator/Darwin, FreeBSD und andere BSD-Varianten, DOS (16 Bit oder 32 Bit DPMI), OS/2, AIX, Android, Haiku, Nintendo GBA/DS/Wii, AmigaOS, MorphOS, AROS, Atari TOS und verschiedene Embedded-Plattformen. Zusätzlich ist in der Entwicklungsversion Unterstützung für RISC-V (32/64), Xtensa und Z80 Architekturen und für die LLVM Compiler Infrastruktur verfügbar. Zusätzlich betreut das Free Pascal Team einen Transpiler für Pascal nach Javascript namens pas2js.

Aktuelle Version

Version 3.2.2 ist die letzte stabile Version von Free Pascal. Klicken Sie auf den Download-Link und wählen Sie einen Spiegel in Ihrer Nähe, um Ihre Kopie herunterzuladen. Die Entwicklungsversionen haben die Versionsnummern 3.3.x. Auf der Entwicklungsseite erfahren Sie, wie Sie die neuesten Quellen erhalten und die Entwicklung unterstützen können.

Funktionen

Die Sprachsyntax ist sehr gut kompatibel mit TP 7.0 sowie mit den meisten Versionen von Delphi (Klassen, rtti, Exceptions, AnsiString's, WideString's, Interfaces). Es gibt auch einen Mac Pascal Modus, der weitgehend kompatibel mit Think Pascal und MetroWerks Pascal ist. Darüber hinaus unterstützt Free Pascal Funktionsüberladung, Operatorüberladung, globale Eigenschaften und einige andere zusätzliche Funktionen.

Erforderlich

x86-Architektur:

Für die 80x86-Version ist mindestens ein 386er Prozessor erforderlich, ein 486er wird jedoch empfohlen.

Die Mac OS X-Version erfordert Mac OS X 10.4 oder höher, wobei die Entwicklerwerkzeuge installiert sein müssen.

PowerPC-Architektur:

Jeder PowerPC-Prozessor ist geeignet. 16 MB RAM sind erforderlich. Es wird erwartet, dass die Mac OS classic Version mit System 7.5.3 und höher funktioniert. Die Mac OS X Version benötigt Mac OS X 10.3 oder später (kann für 10.2.8 oder später kompiliert werden), mit den installierten Entwicklerwerkzeugen. Auf anderen Betriebssystemen läuft Free Pascal auf jedem System, dass das Betriebssystem ausführen kann.

ARM-Architektur:

16 MB RAM sind erforderlich. Läuft auf jeder ARM-Linux-Installation.

Sparc-Architektur:

16 MB RAM sind erforderlich. Läuft auf jeder Sparc-Linux-Installation (Solaris ist experimentell).

Lizenz

Die Pakete und die Laufzeitbibliothek stehen unter einer modifizierten Library GNU Public License, um die Verwendung statischer Bibliotheken bei der Erstellung von Anwendungen zu ermöglichen. Der Quellcode des Compilers selbst steht unter der GNU General Public License. Die Quellen sowohl für den Compiler als auch für die Laufzeitbibliothek sind verfügbar; der komplette Compiler ist in Pascal geschrieben.

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: HTML-Hilfedokumente einfach erstellen


Benutzerhanbuch

PASCAL

Benutzerhandbuch

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Konvertieren Sie Ihre WinHelp HLP-Hilfedateien ganz einfach in CHM mit der Schritt-für-Schritt-Anleitung von HelpNDoc


Referenz-Handbuch

PASCAL

Referenz-Handbuch

Über dieses Handbuch

Dieses Dokument dient als Referenz für die Sprache Pascal, wie sie durch den Free Pascal Compiler implementiert ist. Es beschreibt alle Pascal-Konstrukte, die von Free Pascal unterstützt werden, und listet alle unterstützten Datentypen auf. Es vermittelt jedoch keine detaillierten Erklärungen der Pascal-Sprache: Es ist kein Anleitungsheft.

Das Ziel ist es, zu zeigen, welche Pascal-Konstrukte unterstützt werden und wo sich die Free Pascal-Implementierung von den Turbo Pascal- oder Delphi-Implementierungen unterscheidet.

Die Turbo Pascal und Delphi Pascal Compiler führten verschiedene Features in die Pascal Sprache ein. Der Free Pascal Compiler imitiert diese Compiler im entsprechenden Modus des Compilers: bestimmte Funktionen sind nur verfügbar, wenn der Compiler in den entsprechenden Modus versetzt wird.

Wenn ein bestimmtes Feature benötigt wird, ist die Verwendung des -M Kommandozeilenschalters oder der Direktive {$MODE } im Quelltext erforderlich. Weitere Informationen über die verschiedenen Einstellungen finden Sie im Benutzerhandbuch und im Programmiererhandbuch.

Bezeichnungen

In diesem Dokument werden Funktionen, Typen und Variablen mit Schreibmaschinenschrift gekennzeichnet.

Auf Dateien wird mit einer Sans-Schrift Bezug genommen: Dateiname.

Diagramme zur Syntax

Alle Elemente der Sprache Pascal werden in Syntaxdiagramme erklärt. Syntaxdiagramme sind wie Flussdiagramme. Das Lesen eines Syntaxdiagramms bedeutet, von der linken Seite zur rechten Seite zu gelangen, indem man den Pfeilen folgt. Wenn die rechte Seite eines Syntaxdiagramms erreicht ist und mit einem einzelnen Pfeil endet, bedeutet, dass das Syntaxdiagramm in der nächsten Zeile fortgesetzt wird. Endet die Zeile an zwei aufeinander zeigenden Pfeilen

dann ist das Diagramm beendet.

Syntaktische Elemente werden wie folgt geschrieben:

Schlüsselwörter, die genau wie im Diagramm eingegeben werden müssen:

Wenn etwas wiederholt werden kann, ist es mit einem Pfeil gekennzeichnet:

Schlüsselwort (keyword): | EBNF:
 | keyword ::= "Schlüsselwort" | keyword

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Erleben Sie eine benutzerfreundliche Oberfläche mit dem Dokumentationstool von HelpNDoc


Die Sprache

PASCAL

Referenz-Handbuch

Über die Sprache Pascal

Die Sprache Pascal wurde ursprünglich um 1970 von Niklaus Wirth entwickelt. Seitdem hat sie sich deutlich weiterentwickelt (mit vielen Beiträgen der verschiedenen Compiler-Entwickler - insbesondere: BORLAND). Die Grundelemente wurden über die Jahre hinweg beibehalten:

  • einfache Satzstruktur, recht ausführlich, aber leicht zu lesen. Ideal für den Unterricht.
  • starke Typisierung.
  • prozedural.
  • Groß- und Kleinschreibung wird nicht berücksichtigt.
  • erlaubt verschachtelte Prozeduren.
  • einfache integrierte Ein- und Ausgaberoutinen.

Mit denTurbo Pascal und Delphi Pascal Compilern wurden verschiedene Funktionen in die Sprache Pascal eingeführt, vor allem eine einfachere Handhabung von Zeichenketten und Objektorientierung.

Der Free Pascal Compiler emuliert großr Teile von Turbo Pascal und Delphi.

Er emuliert diese Compiler in dem entsprechenden Modus des Compilers: bestimmte Funktionen sind nur verfügbar, wenn der Compiler in den entsprechenden Modus geschaltet wurde.

Wenn ein bestimmtes Merkmal mittels Kommandozeilen-Optionen gesetzt wurde, wird der Compiler in den entsprechenden Modus geschaltet. Weitere Informationen über die verschiedenen Modi finden Sie im Benutzerhandbuch und dem Programmiererhandbuch

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Modernisieren Sie Ihre Hilfedateien mit HelpNDocs WinHelp HLP-zu-CHM-Konvertierungstool


Symbole

PASCAL

Referenz-Handbuch

Token / Symbole

Token sind die grundlegenden lexikalischen Bausteine des Quellcodes: Sie sind die "Wörter" der Sprache:

Zeichen werden nach den Regeln der Programmiersprache zu Token zusammengesetzt. Es gibt

fünf Klassen von Token:

  1. Reservierte Wörter: Dies sind Wörter, die in der Sprache eine feste Bedeutung haben. Sie können nicht geändert oder neu definiert werden.
  2. Bezeichner: Dies sind Namen von Symbolen, die der Programmierer definiert. Sie können geändert und wiederverwendet werden. Sie unterliegen den Gültigkeitsregeln der Sprache.
  3. Operatoren: Dies sind in der Regel Symbole für mathematische oder andere Operationen:
    +, -, * und so weiter.
  4. Trennzeichen: Dies sind normalerweise Leerzeichen.
  5. Konstanten: Numerische oder Zeichenkonstanten werden verwendet, um konkrete Werte im Quellcode zu bezeichnen, wie z.B. 1 (Integer-Konstanten) oder 2.3 (Float-Konstanten) oder "String-Konstanten" (die deutsche Bezeichnung für "String" steht für eine Zeichenkette - ein Textteil, der in Pascal durch Hochkommata eingeleitet, und ebenfalls durch ein Hochkammata abgeschlossen wird).

Free Pascal erlaubt alle Zeichen, Ziffern und einige Sonderzeichen in einer Pascal-Quelldatei.

Zugelassene Symbole:

letter:

digit:

hex-digit:

Die folgenden Zeichen haben eine besondere Bedeutung:

' + - * / = < > [ ] . , ( ) : ^ @ { } $ # & %

sowie die folgenden Zeichenpaare:

<< >> ** <> >< <= >= := += -= *= /= (* *) (. .) //

Bei Verwendung in einem Bereichsbezeichner entspricht das Zeichenpaar (. linken eckigen Klammer [.

Ebenso ist das Zeichenpaar .) gleichbedeutend mit der rechten eckigen Klammer ]. Bei der Verwendung für Kommentaren entspricht das Zeichenpaar (* der linkseitigen geschweiften Klammer { und das Zeichenpaar *) der der rechtseitigen geschweiften Klammer }. Diese Zeichenpaare behalten ihre normale Bedeutung in Zeichenfolgenausdrücken

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Einfacher Qt Help-Dokumentationseditor


Kommentare

PASCAL

Referenz-Handbuch

Kommentare

Kommentare sind Teile des Quellcodes, die vom Compiler vollständig verworfen werden. Sie existieren nur zum Nutzen des Programmierers, damit er bestimmte Codestücke erklären kann. Für den Compiler ist es so, als ob die Kommentare nicht vorhanden wären.

Das folgende Codestück demonstriert einen Kommentar:

(* My beautiful function returns an interesting result *)

function Beautiful : Integer;

Die Verwendung von (* und *) als Kommentarbegrenzer stammt aus den allerersten Tagen der Sprache Pascal. Sie wurde größtenteils durch die Verwendung von { und } als Begrenzungszeichen für Kommentare ersetzt, wie im folgenden Beispiel:

{ My beautiful function returns an interesting result }

function Beautiful : Integer;

Der Kommentar kann sich auch über mehrere Zeilen erstrecken:

{

My beautiful function returns an interesting result,

but only if the argument A is less than B.

}

function Beautiful (A,B : Integer): Integer;

Einzeilige Kommentare können auch mit dem Begrenzungszeichen // eingegeben werden:

// My beautiful function returns an interesting result

function Beautiful : Integer;

Der Kommentar reicht vom Zeichen // bis zum Ende der Zeile. Diese Art von Kommentar wurde von der Firma BORLAND im Delphi Pascal Compiler eingeführt.

Free Pascal unterstützt die Verwendung von verschachtelten Kommentaren. Die folgenden Konstrukte sind gültige Kommentare:

(* Dies ist ein Kommentar im alten Stil *)

{ Dies ist ein Turbo Pascal Kommentar }

// Dies ist ein Delphi Kommentar. Alles wird bis zum Zeilenende ignoriert

Nachfolgend sind gültige Arten der Verschachtelung von Kommentaren aufgeführt:

{ Kommentar 1 (* Kommentar 2 *) }

(* Kommentar 1 { Kommentar 2 } *)

{ Kommentar 1 // Kommentar 2 }

(* Kommentar 1 // Kommentar 2 *)

// Kommentar 1 (* Kommentar 2 *)

// Kommentar 1 { Kommentar 2 }

Die letzten beiden Kommentare müssen in einer Zeile stehen. Die beiden folgenden Kommentare führen zu Fehlern:

// gültiger Kommentar { Nicht länger gültig !!

}

und

// gültiger Kommentar (* Nicht längert gültig !!

*)

Der Compiler reagiert mit einem "Ungültiges Zeichen"-Fehler, wenn er auf solche Konstrukte stößt, unabhängig

der Compiler-Option -Mtp.

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Maximieren Sie Ihren PDF-Schutz mit diesen einfachen Schritten


Reservierte Wörter

PASCAL

Referenz-Handbuch

Reservierte Wörter

Reservierte Wörter sind Teil der Pascal-Sprache und können als solche nicht vom Programmierer umdefiniert werden. In den Syntaxdiagrammen werden sie in fetter Schrift dargestellt. Der Pascal Compiler beachtet keine Groß- und Kleinschreibung der Wörter.

Wir unterscheiden zwischen Turbo Pascal und Delphi reservierten Wörtern. Im TP-Modus werden nur die Turbo Pascal reservierten Wörter erkannt, aber die Delphi-Wörter können umdefiniert werden. Standardmäßig erkennt Free Pascal die reservierten Delphi-Wörter.

Reservierte Schlüsselwörter: Turbo Pascal

Reservierte Schlüsselwörter: Objekt Pascal

Reservierte Schlüsselwörter: Modifizierungen

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Benutzerfreundliches Werkzeug zum Erstellen von HTML-Hilfedateien und Hilfewebsites


Turbo Pascal

PASCAL

Referenz-Handbuch

Turbo Pascal

Die folgenden Schlüsselwörter existieren im Turbo Pascal Modus:

absolute
and
array
asm
begin
case
const
constructor
destructor
div
do
downto
else
end

file
for
function
goto
if
implementation
in
inherited
inline
interface
label
mod
nil
not

object
of
operator
or
packed
procedure
program
record
reintroduce
repeat
self
set
shl
shr

string
then
to
type
unit
until
uses
var
while
with
xor

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Qt Help-Dateien auf einfache Weise erstellen


Objekt Pascal

PASCAL

Referenz-Handbuch

Objekt Pascal

Die reservierten Wörter von Object Pascal (verwendet im Delphi- oder Objfpc-Modus) sind die gleichen wie die von Turbo

Pascal, mit den folgenden zusätzlichen Schlüsselwörtern:

as
class
dispinterface
except
exports

finalization
finally
initialization
inline
is

library
on
out
packed
property

raise
resourcestring
threadvar
try

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Optimieren Sie Ihren Dokumentationsprozess mit der HTML5-Vorlage von HelpNDoc


Modifizierungen

PASCAL

Referenz-Handbuch

Modifikatoren

Im Folgenden finden Sie eine Liste aller Modifikatoren. Sie sind nicht unbedingt reservierte Wörter in dem Sinne, dass sie

als Bezeichner verwendet werden können, aber an bestimmten Stellen haben sie eine besondere Bedeutung für den Compiler, d. h. der Compiler betrachtet sie als Teil der Pascal-Sprache.

absolute
abstract
alias
assembler
bitpacked
break
cdecl
continue
cppdecl
cvar
default
deprecated
dynamic
enumerator
experimental
export

external
far
far16
forward
generic
helper
implements
index
interrupt
iocheck
local
message
name
near
nodefault
noreturn

nostackframe
oldfpccall
otherwise
overload
override
pascal
platform
private
protected
public
published
read
register
reintroduce
result
safecall

saveregisters
softfloat
specialize
static
stdcall
stored
strict
unaligned
unimplemented
varargs
virtual
winapi
write

Hinweis:

Vordefinierte Typen wie Byte, Boolean und Konstanten wie maxint sind keine reservierten Wörter.

Sie sind Bezeichner, die in der system.pas Datei deklariert sind. Das bedeutet, dass diese Typen in anderen Einheiten umdefiniert werden können. Der Programmierer wird jedoch nicht dazu ermutigt, dies zu tun, da es viel Verwirrung stiften würde.

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Bringen Sie Ihre Dokumentation mit der integrierten SEO von HelpNDoc auf ein neues Niveau


Bezeichner

PASCAL

Referenz-Handbuch

Bezeichner

Bezeichner bezeichnen vom Programmierer definierte Namen für bestimmte Konstanten, Typen, Variablen, Prozeduren

und Funktionen, Einheiten und Programme. Alle vom Programmierer definierten Namen im Quellcode - außer reservierte Wörter - werden als Bezeichner bezeichnet.

Bezeichner bestehen aus zwischen 1 und 127 signifikanten Zeichen (Buchstaben, Ziffern und dem Unterstrich

Zeichen), von denen das erste ein Buchstabe (a-z oder A-Z) oder ein Unterstrich (_) sein muss.

Das folgende Diagramm zeigt die grundlegende Syntax für Bezeichner:

Bezeichner ::= letter

| '_' ( letter | digit )

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Maximieren Sie Ihre Produktivität mit der effizienten Benutzeroberfläche von HelpNDoc


Anhang

PASCAL

Referenz-Handbuch

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: 5 Gründe, warum ein Hilfe-Entwicklungstool für die Dokumentation besser ist als Microsoft Word


Syntax

PASCAL

Referenz-Handbuch

Zahlen (digit): | EBNF:
 | digit ::= 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9
Buchstaben (letter): | EBNF:
 | letter ::= [ A-Z a-z ]
Hexa-dezimale Zeichen: | EBNF:
 | hexdigit ::= digit | ( digit | [ A-F a-f ] )
Bezeichner (ident): | EBNF:
 | ident ::= letter | '_' ( letter | digit )

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Kostenloser Qt Help-Dokumentationsgenerator


Lazarus IDE

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Konvertieren Sie Ihre Markdown-Inhalte mühelos mit HelpNDoc


LCL - Dokumentation

PASCAL

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: CHM, PDF, DOC und HTML Hilfeerstellung von einer einzigen Quelle aus


Control.pas

Controls.pas

Package: LCL

| Klassen | Typen | Methoden | Konstanten

Index

| A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | X | Y | Z |

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Erzielen Sie professionelle Dokumentationsergebnisse mit einem Hilfe-Entwicklungstool


Klassen

Controls.pas

Package: LCL

Pascal - Klassen

Beschreibung

Controls.pas

LCL

| Klassen | Typen | Methoden | Konstanten

Index

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Maximieren Sie Ihre Dokumentationseffizienz mit einem Hilfe-Autorentool


Typen

Controls.pas

Package: LCL

Pascal - Typen

Beschreibung

Controls.pas

LCL

| Klassen | Typen | Methoden | Konstanten

Index

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Erweitern Sie Ihre Hilfedokumentation mit einem Hilfe-Autorentool


Methoden

Controls.pas

Package: LCL

Pascal - Methoden

Beschreibung

Controls.pas

LCL

| Klassen | Typen | Methoden | Konstanten

Index

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Erstellen Sie mühelos professionelle Dokumentation mit der übersichtlichen Benutzeroberfläche von HelpNDoc


Konstanten

Controls.pas

Package: LCL

Pascal - Konstanten

Beschreibung

Controls.pas

LCL

| Klassen | Typen | Methoden | Konstanten

Index

| A | B | C | D | F | G | M | O | S |

A

AnchorAlign

AnchorReferenceSide

asrLeft

asrRight

B

bvLowered

bvNone

bvRaised

bvSpace

C

ClockwiseAnchor

CM_ACTIONEXECUTE

CM_ACTIONUPDATE

CM_ACTIVATE

CM_ALLCHILDRENFLIPPED

CM_APPKEYDOWN

CM_APPSHOWBTNGLYPHCHANGED

CM_APPSHOWMENUGLYPHCHANGED

CM_APPSYSCOMMAND

CM_BASE

CM_BIDIMODECHANGED

CM_BORDERCHANGED

CM_BUFFEREDPRINTCLIENT

CM_BUTTONPRESSED

CM_CANCELMODE

CM_CHANGED

CM_CHILDKEY

CM_COLORCHANGED

CM_CONTROLCHANGE

CM_CONTROLLISTCHANGE

CM_CONTROLLISTCHANGING

CM_CREATEPOPUP

CM_CTL3DCHANGED

CM_CURSORCHANGED

CM_CUSTOMGESTURESCHANGED

CM_DEACTIVATE

CM_DESIGNHITTEST

CM_DESTROYHANDLE

CM_DIALOGCHAR

CM_DIALOGHANDLE

CM_DIALOGKEY

CM_DOCKCLIENT

CM_DOCKNOTIFICATION

CM_DOCWINDOWACTIVATE

CM_DOUBLEBUFFEREDCHANGED

CM_DRAG

CM_ENABLEDCHANGED

CM_ENTER

CM_EXIT

CM_FLOAT

CM_FOCUSCHANGED

CM_FONTCHANGE

CM_FONTCHANGED

CM_GESTURE

CM_GESTUREMANAGERCHANGED

CM_GETDATALINK

CM_GOTFOCUS

CM_HINTSHOW

CM_HINTSHOWPAUSE

CM_HITTEST

CM_ICONCHANGED

CM_INPUTLANGCHANGE

CM_INVALIDATE

CM_INVALIDATEDOCKHOST

CM_INVOKEHELP

CM_ISSHORTCUT

CM_ISTOOLCONTROL

CM_LCLOFFSET

CM_LOSTFOCUS

CM_MENUCHANGED

CM_MOUSEACTIVATE

CM_MOUSEENTER

CM_MOUSELEAVE

CM_MOUSEWHEEL

CM_PARENTBIDIMODECHANGED

CM_PARENTCOLORCHANGED

CM_PARENTCTL3DCHANGED

CM_PARENTDOUBLEBUFFEREDCHANGED

CM_PARENTFONTCHANGED

CM_PARENTSHOWHINTCHANGED

CM_PARENTTABLETOPTIONSCHANGED

CM_POPUPHWNDDESTROY

CM_RECREATEWND

CM_RELEASE

CM_SETACTIVECONTROL

CM_SHOWHINTCHANGED

CM_SHOWINGCHANGED

CM_STANDARDGESTURESCHANGED

CM_SYSCOLORCHANGE

CM_SYSFONTCHANGED

CM_TABLETOPTIONSCHANGED

CM_TABSTOPCHANGED

CM_TEXTCHANGED

CM_THEMECHANGED

CM_TIMECHANGE

CM_UIACTIVATE

CM_UIDEACTIVATE

CM_UNDOCKCLIENT

CM_UNTHEMECONTROL

CM_UPDATEACTIONS

CM_VISIBLECHANGED

CM_WANTSPECIALKEY

CM_WINDOWHOOK

CM_WININICHANGE

CN_BASE

CN_CHAR

CN_CHARTOITEM

CN_COMMAND

CN_COMPAREITEM

CN_CTLCOLORBTN

CN_CTLCOLORDLG

CN_CTLCOLOREDIT

CN_CTLCOLORLISTBOX

CN_CTLCOLORMSGBOX

CN_CTLCOLORSCROLLBAR

CN_CTLCOLORSTATIC

CN_DELETEITEM

CN_DRAWITEM

CN_HSCROLL

CN_KEYDOWN

CN_KEYUP

CN_MEASUREITEM

CN_NOTIFY

CN_PARENTNOTIFY

CN_SYSCHAR

CN_SYSKEYDOWN

CN_SYSKEYUP

CN_VKEYTOITEM

CN_VSCROLL

crAppStart

crArrow

crCross

crDefault

crDrag

crHandPoint

crHelp

crHigh

crHourGlass

crHSplit

crIBeam

crLow

crMultiDrag

crNo

crNoDrop

crNone

crSize

crSizeAll

crSizeE

crSizeN

crSizeNE

crSizeNESW

crSizeNS

crSizeNW

crSizeNWSE

crSizeS

crSizeSE

crSizeSW

crSizeW

crSizeWE

crSQLWait

crUpArrow

crVSplit

csMultiClicks

D

DefaultSideForAnchorKind

F

fsAllNonSystemStayOnTop

fsAllStayOnTop

fsBorder

fsSurface

G

GUID_ObjInspInterface

M

MainAlignAnchor

mrAbort

mrAll

mrCancel

mrClose

mrIgnore

mrLast

mrNo

mrNone

mrNoToAll

mrOK

mrRetry

mrYes

mrYesToAll

O

OppositeAnchor

S

ssModifier

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Gratis PDF-Dokumentationsgenerator


LCL - Komponenten

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: EPub-EBooks mit Leichtigkeit generieren


LCL - Tipps

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Konvertieren Sie Ihre Markdown-Inhalte mühelos mit HelpNDoc


LCL - Beispiele

www.freepascal.org

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Gratis EBook und Dokumentationsgenerator


dBASE

Kommentare

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Erleben Sie die Leistungsfähigkeit und Einfachheit der Benutzeroberfläche von HelpNDoc


Prolog

sf

sdfsd

sd

fd

sf

dsf

ds

f

dsf

sdf

dsf

ds

dsf

dsf

ds

f

dsf

ds

dsf

d

fs

dfs

ds

f

dsf

dsf

ds

dsf

dfs

ds

dsf

dsf

ds

dfs

dsf

dsf

ds

dfs

dfs

dsf

dsf

d

sf

ds

dsf

ds

f

dsf

dfs

d

sf

dsf

dfs

dsf

d

fsd

fs

dsf

ds

ds

dsf

dfs

dfs

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: iPhone-Dokumentation einfach erstellen


Lisp

(C) 2023 by Jens Kallup - paule32

lizenziert unter der Creative Common Lizenz NC

Mit dem Personal Edition von HelpNDoc erstellt: Verwandeln Sie Ihr Word-Dokument mit HelpNDoc in ein professionelles eBook